Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Intermittent incorrect IP returned for A lookups across many domains

I am using both the 64.6.64.6 and 64.6.65.6 public DNS, and randomly experiencing an incorrect IP being returned on various public domain records, across many different domains.

Domains that I have tested using a script:
var domains = [
"vimeo.com",
"www.google.com",
"prod-abc-site.aws.seabc.go.com",
"www.verisign.com",
"api.edgecast.com"
];

Some of the IPs that are being incorrectly returned for A record lookup on any of the above domains:
10.10.30.127 (IANA private range)
172.25.0.190 (IANA private range)
192.168.99.240 (IANA private range)
69.36.150.22 (VeriSign Infrastructure & Operations)
198.55.224.35 (Nasdaq, Inc.)

It's really sporadic, as in 1 request out of 300 might return the incorrect IP, but it's causing my all kinds of grief on my end due to timeouts, ssl cert mismatches when connecting to the wrong IP, those types of things.

Hope you can sort it out. Please let me know when it's fixed and what the issue was. I imagine this has to be happening for other folks as well. I started noticing it in our logs on 2017-12-05T20:50:34.510Z and it has escalated in frequency since then.

Comments

  • Thank you for the information. We are reviewing at this time.
  • Thanks for looking. On my end, it looks like it cleared up at 2017-12-07T20:49:08.105Z. Can you confirm that you identified the issue and have resolved it? Any further details would be appreciated as to the root cause. Thanks again for the quick response.
  • Yes, the issue was discovered and resolved yesterday.
This discussion has been closed.